Aide - Recherche - Membres - Calendrier
Version complète : Problème partie client depuis hier matin (résolu)
Forum osCommerce-fr > Oscommerce 2.3 > Installation - fonctionnement
kikebou
Bonjour,

ma boutique tourne depuis quelques années: osCommerce Online Merchant v2.3.3.4 et, depuis hier matin, cela bug du côté client. J'ai encore eu des commandes ce dimanche.
Donc: impossible de créer un nouveau client (le formulaire s'affiche et on remplit les cases mais, quand on valide la page, on retourne à un formulaire vierge). Impossible de se conecter: même chose quand on valide: le mot de passe disparait. Quand on clique sur un produit, il s'ajoute au panier mais, dès qu'on charge une nouvelle page ou que l'on veut ajouter un autre produit, le panier est de nouveau vide. On peut surfer normalement

Côté admin, tout va bien.

Je suppose que c'est un problème de requête ou une boucle qui s'est mise en place mais j'avoue ne pas être programmatrice et ne pas savoir par où commencer pour savoir où est le soucis (à part réinstaller le site ou vérifier page par page).

En attendant que tout revienne à la normale, j'ai noté aux clients potentiels de me contacter directement part mail pour faire leur commande, mais bon, ce n'est pas une solution à long terme.

Merci d'avance pour votre aide
Bonbec
Bonjour,

Ton site n'a pas apprécié le changement d'heure ? happy.gif
Blague à part, si tu n'as rien modifié sur ton site qui a provoqué le soucis évoqué, c'est sans doute un problème de sessions.
Elles sont sauvegardées dans la BDD ou dans un répertoire ?
Si c'est en BDD, regarde si ta table sessions est énorme.
Si c'est dans un répertoire genre TMP, il est peut-être plein à craquer.

PS : tu peux m'envoyer l'url de ton site par MP S'il te plait ?
kikebou
Merci pour la réponse. Tout refonctionne correctement. je me demande si ce n'est pas l'hébergeur du site qui avait un problème (bien qu'il m'a dit que cela ne venait pas de lui): ce matin, le site n'était plus accessible (nom de domaine introuvable) pendant 2h; même chose pour un autre nom de domaine que j'ai chez eux. Depuis que c'est rétabli, mon site fonctione corretcement. De plus, hier, pas possible de me connecter à la base de données (soit-disant mot de passe incorrect, alors, qu'aujourd'hui, je m'y connecte sans problème.

Sinon, pour répondre à ta question: les sessions sont sauvegardées sur la BDD à la rubrique "sessions". Il y en a pour 16 pages de sessions.

Je vais mettre un "résolu" pour l'instant. S'il y a de nouveau un soucis, je reprendrai le fil du sujet. En tout cas, merci; vous êtes toujours au taquet depuis autant d'années.
Ceci est une version "bas débit" de notre forum. Pour voir la version complète avec plus d'informations, la mise en page et les images, veuillez cliquer ici.
Invision Power Board © 2001-2019 Invision Power Services, Inc.