Aide - Recherche - Membres - Calendrier
Version complète : [résolu] Problème d'installation et modules standards
Forum osCommerce-fr > Vie du groupe > Archives
audisport
Salut à tous,

J'ai installé la dernière version MS2 sans aucun problème particulier. Par contre depuis l'admin quand je clique sur EXPEDITION ou PAIEMENT je n'ai que des pages vides et donc pas d'accès à ses deux administrations...

Quelqu'un pourrait il m'aider? Et je n'ai aucun message d'erreur. Lors de saisie d'une commande cela se passe sans probleme également.

Dans l'arborescence par contre j'ai pu voir que dans modules il y avait le shipping et le paiement sous include mais par contre aucun de ses modules sous l'arborescence admin.

Merci d'avance pour votre aide.
loiclebelge
c'est la quel de MS2 ?

car moi je suis entrainde finir et je vais la lancer et j'ai aucun probs c'est celle de Delaballe


a+
audisport
C'est la version de "Dellaballe"...

Personne ne peut m'aider car la je suis vraiment bloqué...Depuis le menu admin quand je clique sur "modules" uniquement une page blanche apparait et sans aucun message d'erreur...

Merci d'avance, ce serait super si quelqu'un pourrait me débloquer...
Gnidhal
1- vérifie les chemins dans le configure.php de l'admin
2- vérifie que les rep de la partie catalogue ont bien des scripts dans les rep shipping et payment
3 - refais un transfert en mode binaire de ces scripts.

Les scripts de paiement et de mode de transport sont "autoinstallables" depuis les répertoires include/modules/payment et shipping de la partie "catalog". Donc si ces scripts ne sont pas accessibles (pb de chemin) absents ou illisibles, ils ne sont pas vus dans l'admin.
audisport
En fait ses scripts marchent, puis qu'il me font les calculs par défauts lors d'une prise de commande normale.

Le problème c'est dans l'admin, lorsque je clique sur modules une simple page blanche apparait...

J'ai retransféré en binaire, toujours sans succès...
J'ai vérifié le fichier admin/includes/configure.php mais il me semble correct...

je suis vraiment lâché... voici une copie d'une partie du fichier:

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module
define('DIR_FS_DOCUMENT_ROOT', '/home/sites/site28/web/ms2fr/catalog/'); // where the pages are located on the server
define('DIR_WS_ADMIN', '/ms2fr/catalog/admin/'); // absolute path required
define('DIR_FS_ADMIN', '/home/sites/site28/web/ms2fr/catalog/admin/'); // absolute pate required
define('DIR_WS_CATALOG', '/ms2fr/catalog/'); // absolute path required
define('DIR_FS_CATALOG', '/home/sites/site28/web/ms2fr/catalog/'); // absolute path required
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

define('USE_PCONNECT', 'false'); // use persisstent connections?
define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

Merci encore d'avance pour votre aide.
xaglo
question bête... mais des fois wink.gif :
ton admin est DANS le repertoire catalog???

autre chose, essaie de virer le dernier / du define('DIR_FS_DOCUMENT_ROOT')
CODE
define('DIR_FS_DOCUMENT_ROOT', '/home/sites/site28/web/ms2fr/catalog');


http://www.oscommerce-fr.info/forum/index.php?showtopic=#entry8015 pour t'aider à trouver les bugs possibles
audisport
En effet dans MS2 il semblerait que le dossier ADMIN se trouve dans catalog. En tous les cas je n'ai rien changé.

J'arrive vraiment pas à trouver ce bug...après avoir consulter la structure du programme il semblerait que dans /catalog/includes/modules on y trouve bien les dossiers et fichiers shipping, paiement, etc... par contre dans /catalog/admin/includes/modules ces dossiers sont manquants...et pourtant ils n'étaient pas dans le fichier zip que j'ai téléchargé...

Est-ce que l'erreur pourrait venir de la, due la raison pour laquelle tout marche à merveille mais je ne peut pas administrer le shipping et le paiement? Que dois-je faire dans ces cas pour retrouver ses dossiers si tel est le cas?

Merci beaucoup encore
Gnidhal
mais ces fichiers NE doivent PAS être dans admin, seulement dans catalog !
c'est le chemin spécifique du configure.php qui pointe sur les rep de catalog.
depuis l'admin on va lire le contenu de catalog/includes/modules/payment
pareil pour shipping.

Donc il faut que tu vérifies le chemin de
DIR_FS_CATALOG et
DIR_FS_CATALOG_MODULES
dans le configure.php de l'admin pour vérifier qu'ils pointent bien sur le répertoire du catalog.

Est-ce plus clair ?
audisport
Cela me parait logique, merci gnidhal.

Cependant voici mes chemins et ils me semblent corrects...

define('DIR_WS_ADMIN', '/ms2fr/catalog/admin/'); // absolute path required
define('DIR_FS_ADMIN', '/home/sites/site28/web/ms2fr/catalog/admin/'); // absolute pate required
define('DIR_WS_CATALOG', '/ms2fr/catalog/'); // absolute path required
define('DIR_FS_CATALOG', '/home/sites/site28/web/ms2fr/catalog/'); // absolute path required

et

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

c'est juste non?

Merci d'avance pour votre aide
audisport
parcontre je viens d'ouvrir le fichier admin/modules.php et je m'aperçois qu'il est totalement vide...est-ce normal?

merci
audisport
PROBLEME RESOLU!

En fait durant l'installation pour je ne sais quel raison le fichier modules.php a été vidé...

Maintenant cela a l'air de marcher à merveille.

Merci encore
Ceci est une version "bas débit" de notre forum. Pour voir la version complète avec plus d'informations, la mise en page et les images, veuillez cliquer ici.
Invision Power Board © 2001-2014 Invision Power Services, Inc.