osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> http ---> https oscommerce chez ovh, modifications fichiers php pour HTTPS
templier
posté 10 Feb 2017, 18:24
Message #1


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 5
Inscrit : 10-February 17
Membre no 32810



Bonsoir à tous ,

je suis heberge par OVH je désire passer tout mon site en HTTPS avec le certificat SSL gratuit OVH , j'ai réussi sans problemes pour 4 sites , mais pour le site oscommerce je patine dans la semoule !

1) j'ai activé SSL chez OVH
2) j'ai modifié .htacces
3) j'ai modifié includes/configuration.php
4) j'ai modifié administrator/includes/configure.php

a ce stade mes pages affichent du texte ligne par ligne avec des liens incliquables !!

quelqu'un a t il une idée sur ce qui me bloque ?

merci
bonne soirée
Go to the top of the page
 
templier
posté 12 Feb 2017, 19:11
Message #2


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 5
Inscrit : 10-February 17
Membre no 32810



Bonsoir à toutes et tous ,

Personne pour me donner un coup de main ?
Go to the top of the page
 
Bonbec
posté 12 Feb 2017, 22:10
Message #3


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,

Soyez le bienvenu parmi nous.

Citation (templier @ 10 Feb 2017, 18:24) *
... a ce stade mes pages affichent du texte ligne par ligne avec des liens incliquables !! ...

Vu cette description, on dirait que les CSS ne sont pas appliqués sur les pages, je me trompe ?
Il y a peut-être un ou plusieurs "http" codés en dur dans le code.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
templier
posté 13 Feb 2017, 09:15
Message #4


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 5
Inscrit : 10-February 17
Membre no 32810



bonjour ,

merci pour votre réponse.
je n'ai eu aucun problème pour 2 sites classiques (fait a l'ancienne sans CMS , ou je maitrise tout html,php,css etc..)
je n'ai eu aucun problème pour 2 sites joomla

mais pour celui oscommerce je coince grave !

je n'ai aucune idée de ce qui peut bloquer même en faisant appel a https://www.whynopadlock.com/ pour debuger

Go to the top of the page
 
Bonbec
posté 13 Feb 2017, 09:26
Message #5


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,

Une url où on peut voir le soucis ?
Si cela dérange de le rendre public, il est possible de me l'envoyer en MP.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
templier
posté 13 Feb 2017, 09:46
Message #6


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 5
Inscrit : 10-February 17
Membre no 32810



A ce jour j'ai annulé les modifs pour repasser en HTTP , je ne pourrai reprendre ce travail que jeudi 16/02/2017.

je posterai le 16/02 le résultat obtenu en modifiant le site

merci , bonne journée


PS: une précision , je m'occupe de ces 5 sites WEB bénévolement car ce sont des sites d'associations dans lesquelles je suis impliqué.
Go to the top of the page
 
Havock
posté 14 Feb 2017, 09:21
Message #7


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 894
Inscrit : 4-February 04
Membre no 1926



Bonjour,

Citation (templier @ 10 Feb 2017, 18:24) *
2) j'ai modifié .htacces
....

a ce stade mes pages affichent du texte ligne par ligne avec des liens incliquables !!


Effectivement c'est un peu vague.

Vu comme tu le présentes j'aurais tendance à penser que ton pb est causé par ton fichier .htaccess.

A la base oscommerce n'est pas conçu pour être en full SSL, donc le SSL ne concerne que certaines pages (Création et gestion de compte clients, passage de commande) et pas d'autres (pages index, pages des différentes rubriques, pages produit ...).

Si tu as paramétré le SSL dans les fichiers de configuration, tu n'as normalement rien à faire dans le .htaccess, sauf des redirection pour le référencement. Fait un essais en supprimant les modifs du fichier .htaccess et regarde ce qui se passe.

Ce message a été modifié par Havock - 14 Feb 2017, 09:22.


--------------------
L'indispensable est en cours de traitement,
L'urgent sera traité demain,
Le normal sera traité plus tard,
Le reste on vera ...
En conclusion : les journées sont trop courtes.
Utilisateur de MS2.2 Max 1.5 - OSC-Affiliate 1.09 - Admin With Access Levels 2.1 - Meta Tag Controller/ Generator - Credit/Gift Voucher/Coupons 5.05 - Download Controller v5.3 - X-Sell MS2 - WYSIWYG HTML Editor for Admin 1.7 - Dynamic Mo Pics - Loginbox Best - Order logging before payment processing - User Tracking - Faster Page Loads, Less DB queries - Plus plein de modifs perso :-)
Go to the top of the page
 
Bonbec
posté 14 Feb 2017, 13:24
Message #8


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Et au fait, c'est quelle version d'OsCommerce ?


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
templier
posté 15 Feb 2017, 00:17
Message #9


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 5
Inscrit : 10-February 17
Membre no 32810



bonjour ,

oscommerce 2.3.1
Go to the top of the page
 
Bonbec
posté 15 Feb 2017, 08:36
Message #10


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,

Merci pour la version (il faudrait la mettre en signature via le profil).

Il faudra, en plus des modifs des fichiers configure.php (catalog & admin) aller aussi dans l'admin : Configuration -> Sessions et mettre le Check SSL Session ID à True.

Sinon pour le htaccess, un truc comme çà devrait fonctionner :
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]




--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
stbo
posté 13 Mar 2017, 09:50
Message #11


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



Bonjour,
si je comprends bien pour passer mon site v2.2 RC2a en HTTPS il faut :

1) j'ai activé SSL chez OVH (moi aussi)
2) j'ai modifié .htacces

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

3) j'ai modifié includes/configuration.php en ajoutant le S devant le http sur les lignes http://monsite
4) j'ai modifié xxxxxxx/includes/configure.php en ajoutant le S devant le http sur les lignes http://monsite

Y a t'il autre chose à faire ?
Et par chance tout mon site devient Sécurisé ?

EDIT MOD : masquage du répertoire d'administration par mesure de sécurité


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 
Bonbec
posté 13 Mar 2017, 11:13
Message #12


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,

Faire gaffe si il y a des liens en dur (http://) dans les scripts php, js et css

Dans configure.php, penser à modifier cette ligne le false en true :
Code
define('ENABLE_SSL', false);




--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
Havock
posté 14 Mar 2017, 08:32
Message #13


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 894
Inscrit : 4-February 04
Membre no 1926



Citation (stbo @ 13 Mar 2017, 09:50) *
j'ai modifié includes/configuration.php en ajoutant le S devant le http sur les lignes http://monsite


Question stupide, mais as tu également renseigné tous les champs de configure.php

Code
define('HTTP_SERVER', 'https://www.tonsite.com'); // eg, http://localhost - should not be empty for productive servers
define('HTTPS_SERVER', 'https://www.tonsite.com'); // eg, https://localhost - should not be empty for productive servers
define('ENABLE_SSL', true); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', '.www.tonsite.com');
define('HTTPS_COOKIE_DOMAIN', '.www.tonsite.com');


--------------------
L'indispensable est en cours de traitement,
L'urgent sera traité demain,
Le normal sera traité plus tard,
Le reste on vera ...
En conclusion : les journées sont trop courtes.
Utilisateur de MS2.2 Max 1.5 - OSC-Affiliate 1.09 - Admin With Access Levels 2.1 - Meta Tag Controller/ Generator - Credit/Gift Voucher/Coupons 5.05 - Download Controller v5.3 - X-Sell MS2 - WYSIWYG HTML Editor for Admin 1.7 - Dynamic Mo Pics - Loginbox Best - Order logging before payment processing - User Tracking - Faster Page Loads, Less DB queries - Plus plein de modifs perso :-)
Go to the top of the page
 
stbo
posté 14 Mar 2017, 20:44
Message #14


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



Bonsoir c'est exactement cela !!

Mais cela ne ma empêché pas d'avoir eu des erreurs !!

Problème mineur résolue du style un style avec le lien complet en http !!

Mais un autre que je n'arrive pas à résoudre c'est celui ci

Code
'http://www.bijouxdecharme.info/advanced_search_result.php'. This endpoint should be made available over a secure connection.


Pour le moment j'ai désactive la boxe de la colonne mais cela n'est pas la solution.

A part cela tout est bon !!!!!!!!!

Je retire ce que j'ai dis ..

Les pages de catégories et des articles ne sont pas en SSL, il me dit que
Citation
This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information,

alors que les pages d'authentification sont en SSL !!

Et c'est pas fini

il me dit aussi sur la page produit
Code
endpoint 'http://www.bijouxdecharme.info/medaille-coeur-coeurs-argent-graver-avec-photo-et-texte-p-1374.html?action=add_product'. This endpoint should be made available over a secure connection.


Ce message a été modifié par stbo - 14 Mar 2017, 21:25.


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 
Bonbec
posté 14 Mar 2017, 23:55
Message #15


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



J'ai "testé" ton site avec whynopadlock et il me dit :
Citation
Number of items downloaded on page: 73
Valid Certificate found.
Certificate valid through: Jun 12 12:48:00 2017 GMT
Certificate Issuer: Let's Encrypt
SSL Protocols Supported: TLSv1 TLSv1.1 TLSv1.2
All 73 items called securely!


Le test s'est fait en appelant la page d'accueil de ton site en https et non en http.
Les liens de ton menu horizontal sont bien en https. Par contre, les liens pointant vers les articles basculent en http.
Je pense que certains appels au tep_href_link ne contiennent pas l'argument $connection = 'SSL'.

Par défaut, dans catalog/includes/functions/html_output.php :
Code
  function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {

il faudrait essayer de changer le NONSSL en SSL pour voir ce que çà donne. Cela devrait éviter de regarder dans tous les scripts pour ajouter le SSL dans les appels à tep_href_link.
Code
  function tep_href_link($page = '', $parameters = '', $connection = 'SSL', $add_session_id = true, $search_engine_safe = true) {


Tu nous dis si çà change quelque chose ?

PS : par défaut quand on active SSL sur OsCommerce, seules les pages de création de compte, d'identification et du processus de commande passent réellement en SSL.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
stbo
posté 15 Mar 2017, 08:29
Message #16


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



Merci cela n'améliore pas vraiment mais cela ne fait pas de mal, car je ne compte pas revenir en HTTP !!!!
c'est les deux erreurs qui m'embete !!

Code
This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information,

Code
'http://www.bijouxdecharme.info/advanced_search_result.php'. This endpoint should be made available over a secure connection.



----------------------------------------------------------------------------------------------
Suite en cherchant ce message d'erreur provient de la boxe session dans ma colonne de droite

Code
This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information,


POURQUOI ????????



Ce message a été modifié par stbo - 15 Mar 2017, 08:43.


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 
Bonbec
posté 15 Mar 2017, 08:48
Message #17


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Re,

Tu as ces erreurs en appelant ton site pat http ou par https dans l'url ?


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
Havock
posté 15 Mar 2017, 08:53
Message #18


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 894
Inscrit : 4-February 04
Membre no 1926



Citation (stbo @ 15 Mar 2017, 08:29) *
Code
This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information,

Code
'http://www.bijouxdecharme.info/advanced_search_result.php'. This endpoint should be made available over a secure connection.


Suite en cherchant ce message d'erreur provient de la boxe session dans ma colonne de droite

Code
This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information,


POURQUOI ????????


Tu as probablement un formulaire qui dirige vers une page en http et non https.
Tu devrais avoir quelquechose qui ressemble à ça :
Code
tep_draw_form('quick_find', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get', 'role="form"',false,false)

et qui devrais être ça :
Code
tep_draw_form('quick_find', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'SSL', false), 'get', 'role="form"',false,false)


Ce message a été modifié par Havock - 15 Mar 2017, 08:53.


--------------------
L'indispensable est en cours de traitement,
L'urgent sera traité demain,
Le normal sera traité plus tard,
Le reste on vera ...
En conclusion : les journées sont trop courtes.
Utilisateur de MS2.2 Max 1.5 - OSC-Affiliate 1.09 - Admin With Access Levels 2.1 - Meta Tag Controller/ Generator - Credit/Gift Voucher/Coupons 5.05 - Download Controller v5.3 - X-Sell MS2 - WYSIWYG HTML Editor for Admin 1.7 - Dynamic Mo Pics - Loginbox Best - Order logging before payment processing - User Tracking - Faster Page Loads, Less DB queries - Plus plein de modifs perso :-)
Go to the top of the page
 
stbo
posté 15 Mar 2017, 09:26
Message #19


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



1- c'est en appelant le HTTPS

2- modif faite mais pas de changement dans monsite/advanced_search_result.php


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 
stbo
posté 15 Mar 2017, 11:12
Message #20


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



J'ai modifier le fichier search dans le dossier /includes/boxes

Et cela va mieux

J'ai mis des

Code
'NONSSL', false),

en
Code
'SSL', false),


Il me reste encore une ou deux modifs et je verrais un résumé de mes modifs


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 
Havock
posté 15 Mar 2017, 11:33
Message #21


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 894
Inscrit : 4-February 04
Membre no 1926



Le passage en Full SSL a t'il entrainé des modifs au niveau des paramétrages des paiements ? Paypal, Atos ... ?


--------------------
L'indispensable est en cours de traitement,
L'urgent sera traité demain,
Le normal sera traité plus tard,
Le reste on vera ...
En conclusion : les journées sont trop courtes.
Utilisateur de MS2.2 Max 1.5 - OSC-Affiliate 1.09 - Admin With Access Levels 2.1 - Meta Tag Controller/ Generator - Credit/Gift Voucher/Coupons 5.05 - Download Controller v5.3 - X-Sell MS2 - WYSIWYG HTML Editor for Admin 1.7 - Dynamic Mo Pics - Loginbox Best - Order logging before payment processing - User Tracking - Faster Page Loads, Less DB queries - Plus plein de modifs perso :-)
Go to the top of the page
 
stbo
posté 15 Mar 2017, 12:17
Message #22


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



Pas encore essayer !!! biggrin.gif


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 
stbo
posté 15 Mar 2017, 20:43
Message #23


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



Pour passez en SSL total sur mon site, je suis passé par

mon site v2.2 RC2a

1) j'ai activé SSL chez OVH (moi aussi)

2) j'ai modifié .htacces

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

3) j'ai modifié includes/configuration.php en ajoutant le S devant le http sur les lignes http://monsite

4) j'ai modifié xxxxxxx/includes/configure.php en ajoutant le S devant le http sur les lignes http://monsite

5) réglage de quelques problèmes avec le code de catalog/includes/functions/html_output.php :

Code
function tep_href_link($page = '', $parameters = '', $connection = 'SSL', $add_session_id = true, $search_engine_safe = true) {


6) certaines boxe tel que search ou j'ai modifier de code NONSSL en SSL

7) quelques problèmes de lien dans mes descriptifs de catégories et header.php (erreur de ma part d'avoir le lien complet du site)

cool.gif test de paiement OK sur tous les paiements en FULL SSL

9) La partie FO est OK mais pas la partie BO active sur certaine partie seulement!!

Mon plus gros bug c'est que si j'active le code dans la htaccess, j'ai un erreur de code d’accès et impossible de ce connecter mais les page du FO sont toutes en SSL, et si je ne mets pas ce code, connection possible mais toutes les pages en http ne seront pas redirigés

Si une personne a une idée !!!!!

Mais une journée pour passer en FULL SSL c'est trés bien

Par contre l'info du jour !!!!

Allez sur https://letsencrypt.org/ c'est gratuit !! cela fournie un certificat SSL NON PAYANT, vous mettez un robot certbot et hop un certificat gratuit recommandé par en autre OVH pour eux qui ont comme moi un VPS

Ce message a été modifié par stbo - 15 Mar 2017, 20:50.


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 
Bonbec
posté 16 Mar 2017, 02:28
Message #24


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Re,

Côté boutique, tu as un problème avec la syntaxe des liens de la box "A découvrir". On dirait qu'il manque le < devant a href des articles, du coup les liens ne sont pas fonctionnels.

Pour la BO, le point 5) est aussi à faire. Tu as sans doute d'autres 'NONSSL' à modifier en 'SSL' dans certains scripts.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
stbo
posté 17 Mar 2017, 12:07
Message #25


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 152
Inscrit : 3-May 09
Lieu : var
Membre no 25242



Je n'arrive pas à régler mon problème de HTTPS sur la partie BO il y a beaucoup d'erreur en SSL.

Est il possible d'avoir le FO en HTTPS activé et seulement la partie BO en HTTP donc pas de HTTPS ?


--------------------
Tout vient à point à qui c'est attendre !!! LOL
Os commerce v2.2 RC2a
Go to the top of the page
 

2 Pages V   1 2 >
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 19th November 2017 - 05:37
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)