osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> pb d'installation en local avec wamp3, Valeur par défaut invalide pour 'customers_dob'
maccoa
posté 26 Feb 2016, 13:40
Message #1


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 1
Inscrit : 26-February 16
Membre no 32717



bonjour à tous.

j'essaye depuis hier d'installer Oscommerce 2.3.4 en local pour une amis.

j'utilise :
win10 x64
wamp3 c'est la que ça coince . sur wamp 2.5 tout se passe bien mais sur la V3 j'ai une erreur sql à l'installation.
Citation
Valeur par défaut invalide pour 'customers_dob'

je suppose que cela vient de la version mysql qui est 5.7.9 alors que sur wamp2.5 c'est 5.6.17.

comment puis je faire ? réinstaller wamp2.5 ? je préférais garder wamp 3 si possible.
convertir le fichier oscommerce.sql qui est dans install pour qu'il soit compatible mais comment?
je suis un poil perdu blink.gif
merci

je viens de commenter
Citation
#customers_dob datetime DEFAULT '0000-00-00 00:00:00' NOT NULL,

plus de problème d'installation mais cela ne resoud pas le problème je pense

Ce message a été modifié par maccoa - 26 Feb 2016, 14:57.
Go to the top of the page
 
bioskop
posté 26 Oct 2016, 22:39
Message #2


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 66
Inscrit : 14-April 03
Membre no 1060



Bonjour,
J'ai exactement le même problème. Personne n'a une petite idée pour résoudre ça ?
Wamp 3.0.6
Version de PHP :5.6.25
Version de MySQL :5.7.14


--------------------
OSC 2.2
Go to the top of the page
 
Bonbec
posté 27 Oct 2016, 19:26
Message #3


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonsoir,

A priori je pense que la solution est visible ici sur le forum US.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
bioskop
posté 27 Oct 2016, 19:46
Message #4


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 66
Inscrit : 14-April 03
Membre no 1060



Merci Bonbec. Effectivement ça résout un problème mais il y en a bien d'autres.
Un retour à MySQL 5.6 m'a permis d'avoir un site de test opérationnel. Wampserver est un peu trop en avance !


--------------------
OSC 2.2
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 20th November 2017 - 20:03
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)