osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Gestionnaire de bannières, Le Gestionnaire de bannières ne fonctionne pas !
pyram
posté 28 Dec 2015, 13:15
Message #1


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 46
Inscrit : 15-January 08
Lieu : Liège (Belgium)
Membre no 20409



Bonjour,

Voici mon WebShop : artisaNails by Nailisa

Vous l'aurez remarqué, ce n'est pas de l'OSC de base !
Depuis que je l'ai installé (en 2008), je ne me suis jamais pris la tête avec les bannières, car je les crée moi-même et les place là où il faut pour qu'elles soient visibles.

Aujourd'hui, j'aurais besoin d'automatiser l'affichage de ces mêmes bannières, mais dans l'Admin de mon site, sous "Outils", le "Gestionnaire de bannières" ne donne absolument aucun résultat; ils ne fonctionne pas et ne modifie strictement en rien mon site !

Pour votre complète information, actuellement j'affiche mon banner au travers du fichier ...\shop\include\header.php avec le code suivant :
Code
<tr>
<td>
  <?=tep_image(DIR_WS_LANGUAGES . $language.'/images/bunner.jpg')?>
</td>
</tr>


L'un d'entre-vous aurait-il l'expérience pour m'aider à le faire fonctionner ?
Car j'en ressens aujourd'hui vraiment le besoin.

D'avance merci à tous ceux qui me liront et qui me répondront.
Et bonne et heureuse année.
Pyram

Ce message a été modifié par pyram - 28 Dec 2015, 14:37.


--------------------
oscommerce-2.2ms2-FR | And more contrib...
Go to the top of the page
 
Bonbec
posté 29 Dec 2015, 08:57
Message #2


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,

Dans une MS2 de base, la bannière s'affiche tout en bas du site.
Le code se trouve dans catalog/includes/footer.php tout à fait à la fin :
Code
<?php
  if ($banner = tep_banner_exists('dynamic', '468x50')) {
?>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
  <tr>
    <td align="center"><?php echo tep_display_banner('static', $banner); ?></td>
  </tr>
</table>
<?php
  }
?>

A priori c'est ce code qu'il te faudrait placer où tu le souhaites dans ta page.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
pyram
posté 29 Dec 2015, 12:44
Message #3


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 46
Inscrit : 15-January 08
Lieu : Liège (Belgium)
Membre no 20409



Salut Bonbec,

En effet, je l'avais vu, mais il ne m'est pas venu à l'idée de simplement remplacer le code !
Je vais donc essayer d'adapter ta proposition dans mon site "test" et je reviens vers toi (et tout le monde) après...

Merci Bonbec wink.gif
Pyram

Ce message a été modifié par pyram - 29 Dec 2015, 12:45.


--------------------
oscommerce-2.2ms2-FR | And more contrib...
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 18th November 2017 - 07:36
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)