osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> installation de oscommerce 2.3 sur xampp 3.2 php 5.5.15
badibad
posté 11 Jun 2015, 07:46
Message #1


Ceinture orange+ OSC
Icône de groupe

Groupe : Membres
Messages : 313
Inscrit : 20-January 05
Lieu : Oyonnax
Membre no 4446



Bonjour à tous,

je me permets de poster un sujet car je n'ai pas trouver de réponse à mon probleme.

Voila je voudrais installer la dernier version de oscommmerce 2.3 sur xampp 3.2 possedant php 5.5.15.
l'installation c'est bien passer mais j'ai 4 erreurs
1 dans le front
Code
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\Users\ephrael\Desktop\Xampp\htdocs\XXXXX\includes\functions\database.php on line 19

et 3 dans l'admin.
Code
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\Users\ephrael\Desktop\Xampp\htdocs\XXXXX\admin\includes\functions\database.php on line 19

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in C:\Users\ephrael\Desktop\Xampp\htdocs\XXXXXX\admin\includes\application_top.php on line 167

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.;C:\Users\ephrael\Desktop\Xampp\php\PEAR') in C:\Users\ephrael\Desktop\Xampp\htdocs\XXXXXX\admin\includes\application_top.php on line 167



je vous remercie d'avance de votre aide.
Go to the top of the page
 
Havock
posté 11 Jun 2015, 09:03
Message #2


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 894
Inscrit : 4-February 04
Membre no 1926



Bonjour badibad.

Le premier message est lié à la version de mysql de Xampp. Tu dois être au moins sur du 5.5 et les fonctions de type mysql doivent être remplacées par des fonctions de type mysqli. Ce qui est surprenant c'est que sur les versions 2.3 ce remplacement est déjà fait. As tu fait un upgrade d'une version antérieure (dans ce cas il est probable que tu ais oublié d'upgrader le fichier database.php) ou une installation directe de la version 2.3.4 ?

Pour ta seconde erreur le sujet a souvent été abordé sur le forum. C'est généralement un problème lié au paramètrage des long_arrays dans php.ini.

Vérifie que dans ton php.ini le register_globals et le register_long_arrays sont off




--------------------
L'indispensable est en cours de traitement,
L'urgent sera traité demain,
Le normal sera traité plus tard,
Le reste on vera ...
En conclusion : les journées sont trop courtes.
Utilisateur de MS2.2 Max 1.5 - OSC-Affiliate 1.09 - Admin With Access Levels 2.1 - Meta Tag Controller/ Generator - Credit/Gift Voucher/Coupons 5.05 - Download Controller v5.3 - X-Sell MS2 - WYSIWYG HTML Editor for Admin 1.7 - Dynamic Mo Pics - Loginbox Best - Order logging before payment processing - User Tracking - Faster Page Loads, Less DB queries - Plus plein de modifs perso :-)
Go to the top of the page
 
badibad
posté 11 Jun 2015, 22:34
Message #3


Ceinture orange+ OSC
Icône de groupe

Groupe : Membres
Messages : 313
Inscrit : 20-January 05
Lieu : Oyonnax
Membre no 4446



Bonsoir et merci de votre réponse,

je suis passer en version 2.3.4 et depuis plus de problème merci
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 23rd November 2017 - 19:22
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)