osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> modification sur un meta (resolu)
thiery
posté 21 Apr 2015, 23:32
Message #1


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 258
Inscrit : 10-November 02
Membre no 574



Bonjour

je cherche à faire une modification sur un meta

dans le meta actuel, il affiche le lien de l'image en 100x80

Code
<meta ="image" content="<?php print HTTP_SERVER . DIR_WS_HTTP_CATALOG . DIR_WS_IMAGES . $product_info['products_image']; ?>" />


je voudrais changer l'information pour afficher le lien vers l'image qui est dans (products_images /image/) au lieu de celle qui est dans (product/ products_image/)

j'ai essayé plusieurs modifications, mais je n'y arrive pas, je n'ai trouvé aucune information sur le net ou le forum pour faire cette modification
une aide serait la bienvenu

en vous remerciant par avance
à bientôt thierry

Ce message a été modifié par thiery - 29 Apr 2015, 08:50.


--------------------
oscommerce 2.3.3.4 , ,easy_populate,Ultimate SEO,Discount Codes,Multiple Produit Manager,Multiorders,
Go to the top of the page
 
thiery
posté 28 Apr 2015, 18:37
Message #2


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 258
Inscrit : 10-November 02
Membre no 574



bonjour
à force de chercher , j'avance un peu dans le problème
j'arrive à crée le lien vers (products_images /image/)
voici les modifications
Code
<?php
$product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pi.products_id                ,pi.image            , pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, "             . TABLE_PRODUCTS_IMAGES . " pi,     ".TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");
$product_info = tep_db_fetch_array($product_info_query);
?>


par contre le lien qui s'affiche n'est pas la bonne image
le lien indique la 1er image qui est dans la base et non celle du produit


voici l'appel du lien
Code
<meta ="image" content="<?php print HTTP_SERVER . DIR_WS_HTTP_CATALOG . DIR_WS_IMAGES . $product_info['image']; ?>" />


par avance merci pour me mêttre sur la voie
à bientôt thierry


--------------------
oscommerce 2.3.3.4 , ,easy_populate,Ultimate SEO,Discount Codes,Multiple Produit Manager,Multiorders,
Go to the top of the page
 
thiery
posté 28 Apr 2015, 19:01
Message #3


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 258
Inscrit : 10-November 02
Membre no 574



re bonjour
résolu il manquait and pi.products_id
thierry

Ce message a été modifié par thiery - 29 Apr 2015, 08:50.


--------------------
oscommerce 2.3.3.4 , ,easy_populate,Ultimate SEO,Discount Codes,Multiple Produit Manager,Multiorders,
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 23rd November 2017 - 08:44
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)