osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Ms3 pour 2015 ??
niko_232
posté 10 Mar 2015, 13:55
Message #1


Ceinture verte OSC
Icône de groupe

Groupe : Membres
Messages : 686
Inscrit : 31-May 05
Lieu : in the land of hicks
Membre no 6041



Pensez vous que 2015 seras l'année de la ms3 ?

si non ne pensez vous pas que le projet ne va jamais repartir.

Je trouve ca bete que en 10 ans, le pionner du CMS e-commerce soit emmené a disparaitre de part la fuite des marchands, developpeur vers d'autres systèmes

Je vous avoue que j'ai toujours ma petite Oscommerce mais pour d'autres activité je suis passé chez le demon PS wink.gif


Et vous vous voyez comment l'avenir de osc en 2015, pensez vous qu'une sortie de la ms3 en 2016 ou 2017 va permettre de faire revivre le projet comme odoo tente de le faire pour tinyerp par exemple.



--------------------
Go to the top of the page
 
Bonbec
posté 10 Mar 2015, 14:33
Message #2


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1323
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,

Je ne le pense pas, mais il est toujours permit de rêver que ma pensée soit fausse wub.gif

En fait, si on suit le forum anglophone, on se rend compte qu'il y a 3 projets paralèles.
1) la fameuse MS3 (dont on ne parle presque plus)
2) la MS2 avec ses déclinaisons intermédiaires (2.3, 2.3.1, 2.3.2, 2.3.3 et la 2.3.4) qui sont opérationnelles. Elles sont destinées, officiellement, à passer en douceur du code "poussif" de la MS2.2 à la MS3.
A noter que la 2.3.4 a une version non officielle (mais qui a de très nombreux fils de discussion sur le forum officiel anglophone), c'est une version Bootstrap, autrement dit "responsive design". Cette version sert de test en grandeur nature pour que ce soit inclus dans la version 2.4 qui devrait sortir cette année.
3) la version 2.4 dont je viens de glisser un mot la ligne juste au dessus.

Pour ceux comme moi qui ne sont pas des codeurs professionnels, il y a un gros changement de code en cours (depuis la version 2.3.x), ce qui veut dire qu'une multitude d'addon ne sont pas compatibles et il faut les réécrire.
J'ai bien peur qu'une nouvelle fracture de ce type s'éffectue pour la 2.4.

Perso j'ai testé les différentes versions 2.3.x en local.
Ma conclusion, qui est toute personnelle, c'est que si on démarre une nouvelle boutique, il vaut mieux passer directement à une version récente.
Par contre, si comme moi on a une boutique MS2.2 très fortement bricolée et adaptée à mon activité, cela devient très galère d'assurer les différentes mises à jour. Du coup, je reste en MS2.2 que j'ai passé en Php5.4 et comme l'avenir est au "responsive", je suis en train (mais je galère quand même car les nuits sont courtes) de la passer en responsive en incorporant Bootstrap. Je suis assez à l'aise avec le code de la MS2.2, c'est aussi ce qui me pousse à rester avec cette version.
Une fois mon passage en responsive, le code original d'OsCommerce aura quand même assez été changé. Ce qui veut dire qu'en cas d'ajout d'un nouvel addon, je devrais d'abord le modifier et interprêter les modifs à faire par rapport au mode d'emploi pour que cela fonctionne.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
niko_232
posté 11 Mar 2015, 09:45
Message #3


Ceinture verte OSC
Icône de groupe

Groupe : Membres
Messages : 686
Inscrit : 31-May 05
Lieu : in the land of hicks
Membre no 6041



Merci pour ta réponse Bonbec, et bonne chance avec bootstrap wink.gif


--------------------
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 20th November 2017 - 20:11
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)