osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Impossible d'accèder a la page admin
aquaboat
posté 16 Nov 2014, 14:36
Message #1


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 181
Inscrit : 31-March 08
Lieu : bruay
Membre no 21335



Bonjour,
voilà juste a la fin de l'installation, la dernière page de donne accès au catalogue ou à la page admin,
la page catalogue s'affiche mais avec cet erreur :

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\EasyPHP-DevServer-14.1VC11\data\localweb\catalog\includes\functions\database.php on line 19


et la page admin ne s'affiche pas du tout, et signaler ces erreurs :

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\EasyPHP-DevServer-14.1VC11\data\localweb\catalog\admin\includes\functions\database.php on line 19

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in C:\EasyPHP-DevServer-14.1VC11\data\localweb\catalog\admin\includes\application_top.php on line 167

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.;C:\php\pear') in C:\EasyPHP-DevServer-14.1VC11\data\localweb\catalog\admin\includes\application_top.php on line 167


malgrès une petite recherche, je n'ai rien trouvé.
merci pour votre aide.


--------------------
oscommerce - V2.4 english; Avec Easy PHP 2.0
Template english
Go to the top of the page
 
aquaboat
posté 18 Nov 2014, 21:06
Message #2


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 181
Inscrit : 31-March 08
Lieu : bruay
Membre no 21335



je suis parvenue a corriger une des erreurs,
je ne sais pas si j'ai bien fait mais cela fonctionne.

j'ai remplacé :

Code
// Définit le niveau de rapport d'erreurs
error_reporting (E_ALL & ~ E_NOTICE );




par ceci :

Code
// Définit le niveau de rapport d'erreurs
error_reporting (E_ALL & ~ E_NOTICE & ~ E_DEPRECATED);


j'ai voulu essayer ça pour une des deux autre erreurs,
mais le corretif y est dejà.

correctif

encore deux,
si vous avez des pistes, merci wink.gif

Ce message a été modifié par aquaboat - 18 Nov 2014, 21:30.


--------------------
oscommerce - V2.4 english; Avec Easy PHP 2.0
Template english
Go to the top of the page
 
chti_poupon
posté 19 Nov 2014, 10:07
Message #3


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2744
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



Bonjour
Quelle version de 2.3 as-tu installé avec ton easy-php dernier cri?
A te lire !
Chti poupon
Go to the top of the page
 
aquaboat
posté 19 Nov 2014, 12:25
Message #4


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 181
Inscrit : 31-March 08
Lieu : bruay
Membre no 21335



et oui parfois les gens sont c...
je viens de rendre compte de le php 5.5 n'est pas compatible avec le mysql....
Donc je desinstalle mon dernier cri, et je refais un essai avec une version antérieur.

merci


--------------------
oscommerce - V2.4 english; Avec Easy PHP 2.0
Template english
Go to the top of the page
 
chti_poupon
posté 19 Nov 2014, 12:40
Message #5


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2744
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



Errare humanum est, perseverare dabolicum !
La fonction database de la 2.3.4 utilise mysqli, d'où ma question:
Extrait :
Code
<?php
/*
  $Id$

  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com

  Copyright (c) 2013 osCommerce

  Released under the GNU General Public License
*/

  function tep_db_connect($server = DB_SERVER, $username = DB_SERVER_USERNAME, $password = DB_SERVER_PASSWORD, $database = DB_DATABASE, $link = 'db_link') {
    global $$link;

    if (USE_PCONNECT == 'true') {
      $server = 'p:' . $server;
    }

    $$link = mysqli_connect($server, $username, $password, $database);

    if ( !mysqli_connect_errno() ) {
      mysqli_set_charset($$link, 'utf8');
    }

    return $$link;
  }

  function tep_db_close($link = 'db_link') {
    global $$link;

    return mysqli_close($$link);
  }

  function tep_db_error($query, $errno, $error) {
    global $logger;

    if (defined('STORE_DB_TRANSACTIONS') && (STORE_DB_TRANSACTIONS == 'true')) {
      $logger->write('[' . $errno . '] ' . $error, 'ERROR');
    }

    die('<font color="#000000"><strong>' . $errno . ' - ' . $error . '<br /><br />' . $query . '<br /><br /><small><font color="#ff0000">[TEP STOP]</font></small><br /><br /></strong></font>');
  }

  function tep_db_query($query, $link = 'db_link') {
    global $$link, $logger;

    if (defined('STORE_DB_TRANSACTIONS') && (STORE_DB_TRANSACTIONS == 'true')) {
      if (!is_object($logger)) $logger = new logger;
      $logger->write($query, 'QUERY');
    }

    $result = mysqli_query($$link, $query) or tep_db_error($query, mysqli_errno($$link), mysqli_error($$link));

    return $result;
  }

..........................................................

Belle journée !
Go to the top of the page
 
badcape
posté 19 Nov 2014, 17:21
Message #6


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 1067
Inscrit : 28-September 07
Lieu : Saint paul - REUNION
Membre no 19202



...'Dieu m'savonne derrière les oreilles: un "Chti_poupon! tongue.gif

La 2.3.4 ne pose pas de problème sur EasyPHP-DevServer-14.1VC11: ai loadé la version EN puis le patch Fr pour voir la bète et elle "roule"..... où est l'problème?

cool.gif

Oups! 'faut qu'je mette ma signature à jour! ça fait tellement longtemps biggrin.gif

Ce message a été modifié par badcape - 19 Nov 2014, 17:24.


--------------------
Thierry
En prod Server: Percona Server via UNIX socket Percona Server version:10.1.20-MariaDB - Percona Server (GPL),
PHP 5.5.30 phpMyAdmin 4.0.10.6 Database version: MySQL 5.5.5-10.1.20 extension: mysqli
version Oscommerce-2.3.4 bootstrap avec un tas comme ça de contributions ...... et bien d'autres dont je me suis inspiré à grand renfort de café !
Un grand merci à tous !(pour votre aide et votre patience....)
En local: EasyPHP DevServer 14.1 VC9 "Minakami" avec oscom 2.3.4 Bootstrap Gold + KissIT_image thumbnailer, Product fields group, Products Extra Fields, margin report, account_create_in_admin, easy populate, FAQ desk, MATC, SPPC, quick updates for SPPC, slick reCaptcha, modular front page module, Select Product Image Directory, Edit page (page control), Message box, Horizontal categories menu BS, Edit order, Edit invoice, Hide categories with category cache, Related products BS, Ultimate Seo Urls, Withdrawal form for BS... modifiées et d'autre contrib que je teste avant de mettre en prod.
Go to the top of the page
 
aquaboat
posté 19 Nov 2014, 18:22
Message #7


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 181
Inscrit : 31-March 08
Lieu : bruay
Membre no 21335



voilà j'ai réinstaller avec easy php 2.0
php 5.3 un mieux l'admin s'affiche, sauf le catalog .

Parse error: parse error, unexpected '$' in C:\EasyPHP 2.0b1\www\catalog\includes\functions\database.php on line 17

Code
function tep_db_connect($server = DB_SERVER, $username = DB_SERVER_USERNAME, $password = DB_SERVER_PASSWORD, $database = DB_DATABASE, $link = 'db_link') {
    global $$link;

    if (USE_PCONNECT == 'true') {
     'P:' $ = serveur.  $ Serveur;
    }


--------------------
oscommerce - V2.4 english; Avec Easy PHP 2.0
Template english
Go to the top of the page
 
Rusti
posté 19 Nov 2014, 19:10
Message #8


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 83
Inscrit : 11-October 10
Lieu : Villemomble
Membre no 28103



Je comprend pas la 2.3 fonctionne très bien avec PHP5.5 juste quelque modif sur le preg_replace().

Je me trompe ou pas ?


--------------------
osCommerce v2.3
Go to the top of the page
 
aquaboat
posté 19 Nov 2014, 23:23
Message #9


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 181
Inscrit : 31-March 08
Lieu : bruay
Membre no 21335



j'ai egalement essayer l'instalation de osc 2.3.4
avec easy php 14.1
je bloque a la première page, je cliquer sur suivant autant de fois que je le veux,
rien ne se passe.

Ce message a été modifié par aquaboat - 19 Nov 2014, 23:23.


--------------------
oscommerce - V2.4 english; Avec Easy PHP 2.0
Template english
Go to the top of the page
 
chti_poupon
posté 20 Nov 2014, 11:18
Message #10


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2744
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



Bonjour
Ton amie la FAQ se sent seule sans toi.
Visites-la donc ici !

Belle journée !
Chti poupon
Go to the top of the page
 
aquaboat
posté 20 Nov 2014, 19:34
Message #11


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 181
Inscrit : 31-March 08
Lieu : bruay
Membre no 21335



Bon et bien deux jours que j'essai d'installer osc,
j'en suis toujours au même point, pas moyen ...
Grrr, multiple essai et ca même avec la FAQ,
je suis sur suivant a la première page de l'insallation

lla petite roue denté qui tourne sans cesse a coté de cette phrase :
Test de connexion à la base de données.
Je ne sais pas si cela peut y etre pour quelque chose,
mais une croix rouge devant : cURL et OpenSSL.

et rien ne se passe... angry.gif
je vais prendre l'air ..


Ch'ti poupon,
je suis parvenue a installer 2.3
avec easyphp 2.0
j'ai été voir le lins que tu m'a donné la FAQ
pour mon erreur :

Parse error: parse error, unexpected '$' in C:\EasyPHP 2.0b1\www\catalog\includes\functions\database.php on line 17

Il demande d'aller dans easyphp et voir si la base donnée a bien été créer,
mais lorsque clique sur administration d'easyphp, cela me dit également,

Bienvenue à phpMyAdmin 2.9.1.1


La raison probable est que vous n'avez pas créé de fichier de configuration. Vous pouvez utiliser le script de configuration dans ce but.

Erreur
MySQL a répondu:Documentation

#1045 - Acc�s refus� pour l'utilisateur: 'ODBC'@'@localhost' (mot de passe: NON)

Ce message a été modifié par aquaboat - 23 Nov 2014, 07:07.


--------------------
oscommerce - V2.4 english; Avec Easy PHP 2.0
Template english
Go to the top of the page
 
badcape
posté 26 Nov 2014, 17:48
Message #12


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 1067
Inscrit : 28-September 07
Lieu : Saint paul - REUNION
Membre no 19202



... et impossible de te donner un coup d'main par MP: ta boite de réception est pleine!

cool.gif


--------------------
Thierry
En prod Server: Percona Server via UNIX socket Percona Server version:10.1.20-MariaDB - Percona Server (GPL),
PHP 5.5.30 phpMyAdmin 4.0.10.6 Database version: MySQL 5.5.5-10.1.20 extension: mysqli
version Oscommerce-2.3.4 bootstrap avec un tas comme ça de contributions ...... et bien d'autres dont je me suis inspiré à grand renfort de café !
Un grand merci à tous !(pour votre aide et votre patience....)
En local: EasyPHP DevServer 14.1 VC9 "Minakami" avec oscom 2.3.4 Bootstrap Gold + KissIT_image thumbnailer, Product fields group, Products Extra Fields, margin report, account_create_in_admin, easy populate, FAQ desk, MATC, SPPC, quick updates for SPPC, slick reCaptcha, modular front page module, Select Product Image Directory, Edit page (page control), Message box, Horizontal categories menu BS, Edit order, Edit invoice, Hide categories with category cache, Related products BS, Ultimate Seo Urls, Withdrawal form for BS... modifiées et d'autre contrib que je teste avant de mettre en prod.
Go to the top of the page
 
aquaboat
posté 27 Nov 2014, 18:41
Message #13


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 181
Inscrit : 31-March 08
Lieu : bruay
Membre no 21335



Oup's désolé je n'ai pas préter attention,
j'ai vidé la boite. happy.gif


--------------------
oscommerce - V2.4 english; Avec Easy PHP 2.0
Template english
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 24th November 2017 - 14:15
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)