osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> probleme base de donné
zbeuz
posté 16 Apr 2014, 21:32
Message #1


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 6
Inscrit : 16-April 14
Membre no 32614



je souhaite installer oscommerce avec une template j ai bien suivie toute les etapes et tout fonction dans l instalation oscommerce qui reconnait ma base de donné mais quand je vais sur mon site je recois se message

1046 - No database selected

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

[TEP STOP]

et dans phpmyadmin je ne vois aucune table alors que toute mes fichier dans conf son bien configuere je ne comprend plus rien help pls


--------------------
NO PUB
Go to the top of the page
 
chti_poupon
posté 17 Apr 2014, 08:24
Message #2


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2744
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



Bonjour
Pour le bon ordre du forum, il faut remplacer le nom de ton site en signature par la version osCommerce en cause. En effet, la publicité est interdite dans les messages. Sauf pour illustrer un problème particulier, et quand cela ne peut être évité, le nom des sites doit apparaître sous une forme genre "mon_site"
Pour le problème technique évoqué, il faut spécifier la version utilisée, et pour les templates leur nom.
S'il s'agit d'un template commercial, c'est au vendeur d'en assurer l'adaptation et la maintenance.
Si le site ne fonctionne pas en distant, même sans ce template, là, nous pouvons intervenir.
Nous attendons ces modifications et ces précisions.
Bons essais !
Chti poupon
Go to the top of the page
 
zbeuz
posté 17 Apr 2014, 15:21
Message #3


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 6
Inscrit : 16-April 14
Membre no 32614



bonjour,
désoler j ai corriger ma signature

bon comme je vous l ai dit j ai acheter une template theme complete oscommerce j ai fait l installation via ftp directement j ai bien configurer le fichier configure toute est ok meme avec l installation oscommerce il reconnait la base donné est valide toute les etapes

par la suite quand je rend sur mon site http:// ww w .bo un ay .co m/ ve te me nt -e nf an t- jo ue t/://http:// ww w .bo un ay .co m/ ve te... an t- jo ue t/ j ai le message 1146 - Table 'bounaymod1.configuration' doesn't exist select configuration_key as cfgKey, configuration_value as cfgValue from configuration

donc quand je vais faire une verification sur ma base de phpmyadmin il n y a aucune table de transferer et quand je fait un teste avec un fichier php que je transfert sur ftp celui ici est bien transféré sur ma base de donné je ne comprend plus rien
merci de toute l aide que vous pourriez m apporté


--------------------
NO PUB
Go to the top of the page
 
Bonbec
posté 18 Apr 2014, 05:36
Message #4


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1326
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



C'est celui qui t'a vendu le template qui doit te faire le service après vente, désolé.
2 petits trucs en passant :
1) concernant le lien dans ta signature : Lire le paragraphe pub
2) concernant ton template : Lire la FAQ
PS : pour ton Internal Error, il y a 99% de chance que cela provienne de ton .htaccess

Ce message a été modifié par Bonbec - 18 Apr 2014, 05:37.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
zbeuz
posté 18 Apr 2014, 06:12
Message #5


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 6
Inscrit : 16-April 14
Membre no 32614



bonjour
merci pour vos reponses

effectivement etant nouveau sur votre forum et sur oscommerce d ailleurs j avais acheter ce kit template car je trouvais le theme tres jolie mais bon je vois que ce n est pas si simple que cela pour quelqu un qui n est pas expert.

je vous laisse mon code du fichier.haccess de mon site peut etre vous pourriez me dire ce qui ne vas pas merci a vous tous


# $Id$
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
# AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

#<IfModule mod_setenvif.c>
# <IfDefine SSL>
# SetEnvIf User-Agent ".*MSIE.*" \
# nokeepalive ssl-unclean-shutdown \
# downgrade-1.0 force-response-1.0
# </IfDefine>
#</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

php_value session.use_trans_sid 0
php_value register_globals 1



--------------------
NO PUB
Go to the top of the page
 
zbeuz
posté 18 Apr 2014, 18:13
Message #6


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 6
Inscrit : 16-April 14
Membre no 32614



help pls


--------------------
NO PUB
Go to the top of the page
 
chti_poupon
posté 18 Apr 2014, 18:36
Message #7


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2744
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



Bonjour
Les "Up" sont interdits !
Les mentions publicitaires, comme ta signature sont interdites dans le message: aucune correction faite malgré les remarques éclairées ci-dessus de Bonbec !
Une sanction sera donc appliquée sous peu.
Pour ton problème, il faut essayer de faire fonctionner ton site SANS le template acheté (sauvegardes l'état actuel et reprends une installation).
Si -Dans ces conditions - le problème persiste sans ce template, nous pourrons te guider.
Pour ton .htaccess, c'est bizarre, car tout est en commentaire (# ceci est un commentaire) SAUF 2 lignes bien inutiles si tu es bien en 2.3.1 comme dit dans ton autre fil.
Enfin, pour mettre un site en ligne, et sa base, un transfert FTP ne suffit pas: la FAQ - notre bonne amie à tous - est là pour les renseignements : c'est là

En attendant le résultat des essais demandés: Bons essais !!


Chti poupon
Go to the top of the page
 
zbeuz
posté 18 Apr 2014, 19:08
Message #8


Ceinture blanche OSC
Icône de groupe

Groupe : Membres
Messages : 6
Inscrit : 16-April 14
Membre no 32614



merci pour ta reponse
j ai changer mon site sur mon profile c est celui sur le quel j ai un probleme avec os commerce je ne comprend pas ou est le probleme je ne cherche pas a faire de la pub avec un site qui ne fonctionne pas juste essayer d avoir des reponses a mes problemes d installation

je vais supprimer mon site sur mon profile

pour la suite il faudrais que j enleve tout les # ? merci
Go to the top of the page
 
chti_poupon
posté 18 Apr 2014, 20:25
Message #9


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2744
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



NON!
Sauvegardes le contenu distant
Installes d'abord le site osCommerce 2.3.1 SANS TEMPLATE en distant:
télécharges la version de base oscommerce 2.3.1 qui se trouve ici
Transfères la sur ton site par FTP, à la racine du site
Exécutes point par point et dans l'ordre TOUT ce qui est dit à partir du B 3 compris de la FAQ
Va bien jusqu'à la fin.0
Essais
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 23rd November 2017 - 19:26
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)