osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Compatibilité OSC 2.3 avec PHP5.3
zevacu
posté 21 Jul 2011, 14:34
Message #1


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 68
Inscrit : 8-November 05
Lieu : zevaco
Membre no 7753



La question peut paraître stupide, mais je viens de passer quelques heures à bidouiller le code de mon vieil OSC2.2, après une mise à jour de mon hébergeurs vers PHP5.3... La boutique semble tourner mais je ne suis pas sûr que toutes les fonctionnalités aient survécu...
Voulant passer à OSC2.3, je n'ai trouvé nulle part une information sur cette compatibilité.
Quelqu'un en sait-il plus ?


--------------------
Zevacu

OSC 2.334, Ultimate SEO 5 Pro, Headers Tags SEO V.3.3.2 (1), Atos 3.2
Go to the top of the page
 
zevacu
posté 21 Jul 2011, 15:14
Message #2


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 68
Inscrit : 8-November 05
Lieu : zevaco
Membre no 7753



Réponse: non, OSC2.3 n'est compatible avec PHP5.3...
Des fonctions obsolètes (et qui bloquent OSC2.2) subsistent: ereg(), eregi().


--------------------
Zevacu

OSC 2.334, Ultimate SEO 5 Pro, Headers Tags SEO V.3.3.2 (1), Atos 3.2
Go to the top of the page
 
tomguiss
posté 1 Dec 2011, 10:22
Message #3


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 70
Inscrit : 7-February 08
Lieu : Liège, Belgique
Membre no 20711



J'ai un peu le même souci... mon hébergeur a fait une mise à jour sur mon serveur dédié et j'ai maintenant PHP 5.3 et MySQL 5.0.77

j'avais l'OS 2.2 et cela ne marchait plus.... surtout "produit non trouvé"...

je viens d'installer la version 2.3... et j'ai déjà des soucis ! je n'ai pas accès à la partie ADMIN... ca commence bien !


Qu'avez-vous fait ? réadapter la version 2.2 ou installer la version 2.3 ?
Go to the top of the page
 
krokus
posté 1 Dec 2011, 10:51
Message #4


Ceinture orange+ OSC
Icône de groupe

Groupe : Membres
Messages : 337
Inscrit : 23-February 07
Membre no 15518



Bonjour, je n'ai eu aucun soucis de compatibilite
Version PHP: 5.2.17 (Zend: 2.2.0)


--------------------
Ms2.3+Category Description+Ckeditor+Colissimo+EasyPopulate+Header tags seo+Otf autothumb+PIM osSlideshow+Theme switcher+Ultimate Seo Urls+Icone stock+crawlprotect+Who's Online Enhancement+Master password+lien suivi colis
Go to the top of the page
 
chti_poupon
posté 1 Dec 2011, 12:06
Message #5


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2652
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



Bonjour,
+1 avec krokus.
@ tomquiss : tu dus dans un autre message:
Citation
J'ai l'OS 2.2
serveur php : 5.2.17
Mysql 5.0.77

C'est pas php 5.3 çà !
Et les erreurs SQL se traduisent par un message que tu n'as pas, bizarre...
Vérifie pour voir qu'ils ne sont pas désactivés soit par htaccess ou dans le header ou dans le paramétrage du serveur.
Il n'est pas possible de laisser dire que osC 2.2 ne marche pas, quand dans ces mêmes pages quelqu'un voulait moderniser une version 2.1 toujours en exploitation...
Quant à la sécurité, elle est assurée si les précautions recommandées sont suivies (voir FAQ) et aussi sur ta propre machine où tous les accès sont paramétrés !!!

Belle Journée !
Chti poupon
Go to the top of the page
 
tomguiss
posté 1 Dec 2011, 13:49
Message #6


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 70
Inscrit : 7-February 08
Lieu : Liège, Belgique
Membre no 20711



Oui j'ai dit cela mais entre temps mon hébergeur a fait un upgrade également de PHP et le register_globals a été désactivé donc mon ancien OS commerce ne marche meme plus maintenant, et en aucun cas ils ne veulent la mettre à ON
Donc je dois bien repartir à 0 puis réimporter toutes mes commandes et clients.

Sur ma machine, aucun souci, j'ai fait un test et tout ce qu'il fallait faire niveau serveur.

Tout marchait bien depuis 2008 avec plus de 2500 commandes .... puis suite au hack... pas le choix maintenant !
Go to the top of the page
 
chti_poupon
posté 1 Dec 2011, 15:05
Message #7


Ceinture noire OSC
Icône de groupe

Groupe : TechDev
Messages : 2652
Inscrit : 9-September 08
Lieu : Douai
Membre no 22915



Quand on a lu çà, se plaindre de problèmes de sécurité et de hack et rechercher un prestataire qui accepte register_globals à on est pour le moins bizarre.
L'adaptation d'osC 2.2 à register globals off est largement traitée dans ce forum.
Ce n'est pas la version osC2.2 en soi qui a un problème.
Chti poupon
Go to the top of the page
 
FoxP2
posté 1 Dec 2011, 21:37
Message #8


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1665
Inscrit : 3-June 09
Membre no 25501



difficile de dire si il y aura une version 2.3.x dédié à php 5.3 ou directement une version 2.4 compatible avec php 5.4.

Citation
faaliyet
osCcommerce v2.3.1 needs the update to work with PHP5.4! That does not work with PHP5.4. I'm checking out upgrade changes now. Quickly question: When will the new version be released ?
Oct 03 2011, 08:14

Mark Evans
I would hope to release it shortly after PHP 5.4 becomes a final release
Oct 03 2011, 10:24


source : http://forums.oscommerce.com/user/5-mark-e...ge__tab__status

une branch 5.4 est présente sur son compte github : https://github.com/oscsparky/oscommerce2/tree/PHP_54


--------------------


Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 31st October 2014 - 06:32
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)