osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> probleme lightbox
thebeatmaker
posté 30 Apr 2009, 11:07
Message #1


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 66
Inscrit : 10-October 08
Membre no 23231



bonjour,
j'ai un problème d'affichage avec la lightbox, quand celle ci s'ouvre , elle s'affiche bien sous safari mais pas sous firefox ou IE. le problème pour moi viendrait de la css lightbox.css , au niveau de ce code :
CODE
#overlay{

position: absolute;

top: 0;

left: 0;

z-index: 90;

width: 100%;

height: 500px;

background-color: #000;

}


quand je retire " left: 0;" ca fonctionne nickel sur firefox mais pas sous safari .

merci beaucoup pour votre aide
Go to the top of the page
 
NoZic
posté 30 Apr 2009, 11:12
Message #2


Ceinture noire OSC
Icône de groupe

Groupe : Membres
Messages : 2871
Inscrit : 27-June 07
Lieu : Elancourt (78)
Membre no 18127



Bonjour,

La lightbox étant positionnée en absolu, il faut absolument laisser ton left: 0;.

Mais tu ne décris pas le problème, on ne peut deviner quoi faire...

Pas de symptômes, pas de guérison...


--------------------
"Les solutions existent toujours depuis longtemps, il suffit de les trouver."
Go to the top of the page
 
thebeatmaker
posté 30 Apr 2009, 11:45
Message #3


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 66
Inscrit : 10-October 08
Membre no 23231



merci pour ta réponse en fait quand la lightbox s'ouvre elle n'est pas centrer par rapport au site
sous IE

http://upload.mezimages.net/1241088224.light.jpg

sous firefox

http://upload.mezimages.net/1241088275.light2.jpg

merci pour ton aide
Go to the top of the page
 
NoZic
posté 30 Apr 2009, 11:56
Message #4


Ceinture noire OSC
Icône de groupe

Groupe : Membres
Messages : 2871
Inscrit : 27-June 07
Lieu : Elancourt (78)
Membre no 18127



Re,

Je n'ai pas installé (encore) cette contrib'.

Par contre, d'après les screens, il me parait assez évident que la lightbox est contenue dans quelque chose qui l'empêche de passer par dessus ton site. Bah oui, elle est en left: 0; donc commence à gauche à 0px de son conteneur et en width: 100%; donc prend 100% de la largeur de son conteneur, ce qui n'est visuellement pas le cas, elle est donc contenue dans autre chose qui fait la largeur que l'on voit à l'écran. Ou alors, elle est contenue dans quelque chose de décalé par rapport au left: 0; de la page elle même.

C'est comme ça à vue de nez la seule explication qui me vient.

Bon courage


--------------------
"Les solutions existent toujours depuis longtemps, il suffit de les trouver."
Go to the top of the page
 
thebeatmaker
posté 30 Apr 2009, 12:32
Message #5


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 66
Inscrit : 10-October 08
Membre no 23231



ok merci en fait la lightbox passe bien au dessus de mon site , c'est juste qu'elle est décalée, a ton avis il faut que je vois au niveau de la page qui déclenche la lightbox ?
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 20th October 2018 - 21:30
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)