osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Problème, [résolu] après installation certificat ssl
jeanmi
posté 9 Dec 2023, 12:03
Message #1


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 47
Inscrit : 10-November 04
Membre no 3743



Bonjour,

Après installation d'un certificat ssl sur mon site: https://www.artsimport.net, j'ai encore pas mal de problèmes , je ne comprends pas pourquoi le cadenas montre que le site n'est pas sécurisé. Pourtant j'ai vérifié (sur https://www.ionos.fr/tools/ssl-checker) que le certificat est bien installé.

Ca n'empèche pas d'avoir des pop-ups (par exemple si je recherche un produit par la case de recherche) qui mes dit que les informations vont être transmises en clair. Quelqu'un aurait t'il une idée des fichiers que je devrait vérifier en priorité? les fichiers configure.php sont les mêmes que sur un autre site oscommerce qui ne me pose pas de problèmes, ça doit pas venir de la. Alors d'ou?? blink.gif

Merci de vos précieux éclairages.


--------------------
MS2FR;pricebreak 1.11.11;quick update 2.4;easypopulate2.74;freeamount3.2;loginbox 5.5;minimum order;visible_countries_1.1b;print order;
Go to the top of the page
 
Bonbec
posté 9 Dec 2023, 13:13
Message #2


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1543
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,
Je vois que tu es avec un OsCommerce MS2.Sur mon site avec cette version, j'ai eu le même problème.La solution a été de mettre en https le define('HTTP_SERVER' en même temps que le define('HTTPS_SERVER'


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc Phoenix
Go to the top of the page
 
jeanmi
posté 9 Dec 2023, 23:32
Message #3


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 47
Inscrit : 10-November 04
Membre no 3743



Salut Bonbec,

Merci pour ta réponse,


tu veut dire au lieu de :

define('HTTP_SERVER', 'http://www.artsimport.net'); // eg, http://localhost - should not be empty for productive servers
define('HTTPS_SERVER', 'https://www.artsimport.net'); // eg, https://localhost - should not be empty for productive servers
define('ENABLE_SSL', 'true'); // secure webserver for checkout procedure?

Je devrait mettre:

define('HTTP_SERVER', 'https://www.artsimport.net'); // eg, http://localhost - should not be empty for productive servers
define('HTTPS_SERVER', 'https://www.artsimport.net'); // eg, https://localhost - should not be empty for productive servers
define('ENABLE_SSL', 'true'); // secure webserver for checkout procedure?


Je n'ai pas essayé, j'attends ta réponse.


--------------------
MS2FR;pricebreak 1.11.11;quick update 2.4;easypopulate2.74;freeamount3.2;loginbox 5.5;minimum order;visible_countries_1.1b;print order;
Go to the top of the page
 
Bonbec
posté 10 Dec 2023, 07:19
Message #4


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1543
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Oui tout à fait


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc Phoenix
Go to the top of the page
 
jeanmi
posté 10 Dec 2023, 09:18
Message #5


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 47
Inscrit : 10-November 04
Membre no 3743



Merci beaucoup pour ta réactivité.

Ca marche niquel biggrin.gif

Je ne sait pas si je fait bien de mettre ça ici, mais je cherche un développeur oscommerce compétent pour refondre ma boutique, pas facile à trouver, j'ai cherché sur codeur ça a été une catastrophe.

Si quelqu'un lit ce message et connait des devs compétents, merci de m'envoyer les coordonnées en mp.

Merci encore Bonbec.


--------------------
MS2FR;pricebreak 1.11.11;quick update 2.4;easypopulate2.74;freeamount3.2;loginbox 5.5;minimum order;visible_countries_1.1b;print order;
Go to the top of the page
 
jeanmi
posté 10 Dec 2023, 09:21
Message #6


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 47
Inscrit : 10-November 04
Membre no 3743



Encore un truc, je cherche à changé le titre du sujet pour ajouté résolu, j'ai du savoir faire, mais j'ai oublié
confused.gif


--------------------
MS2FR;pricebreak 1.11.11;quick update 2.4;easypopulate2.74;freeamount3.2;loginbox 5.5;minimum order;visible_countries_1.1b;print order;
Go to the top of the page
 
Bonbec
posté 10 Dec 2023, 10:07
Message #7


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1543
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Re,
J'ai modifié le titre du premier message, donc c'est marqué résolu maintenant.Il suffit d'éditer le message pour faire la modif.
Pour la refonte du site, c'est pour rester en MS2 et l'adapter à une version de php récente ou changer en version V4 (la version officielle d'OsCommerce) ou un fork comme Phoenix ?


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc Phoenix
Go to the top of the page
 
jeanmi
posté 10 Dec 2023, 14:45
Message #8


Ceinture jaune OSC
Icône de groupe

Groupe : Membres
Messages : 47
Inscrit : 10-November 04
Membre no 3743



Merci pour le résolu.

Pour la version, je préfèrerais rester en MS2 mais corriger les bugs et des erreurs, au début du site j'avais le temps de corriger moi même, je me débrouillait en y passant du temps, mais il y a 20 ans de ça, la boite a bien évolué et je n'ai plus le temps ni l'envie de passer des heures à trouver le bout de code qui doit changer. J'ai quelques bugs et quelques erreurs, je préfèrerais avoir un bon dev qui peut s'occuper de tout, maintenant j'ai les moyens de payer (un peu biggrin.gif ). J'ai peur qu'a terme avec l'évolution d'internet les sites finissent par rencontrer des problèmes insurmontables, je préfèrerais y penser avant. J'ai penser aussi à faire quelques améliorations.

Après je ne suis pas contre un passage vers une version plus récente, mais il y a du boulot, j'ai 2000 produits et 8000 clients et j'ai bidouillé pas mal de petites choses des fichiers persos qui'il faudrait adapter.

Et j'ai 2 sites en production, donc les 2 à faire évoluer.

Je suis à Auxerre dans l'yonne, au cas ou il y aurait un dev intéréssé, on peut discuter. N'hésitez pas à me MP.


--------------------
MS2FR;pricebreak 1.11.11;quick update 2.4;easypopulate2.74;freeamount3.2;loginbox 5.5;minimum order;visible_countries_1.1b;print order;
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 25th April 2024 - 08:39
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)