osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> toujours mise a jour 2.3-1 vers 2.4, Paypal a changé et demande de modifier
frannyz
posté 20 Jun 2018, 11:41
Message #1


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 83
Inscrit : 19-January 09
Lieu : Morbihan
Membre no 24276




Bonjour de ma Bretagne ou il fait très beau
tout marchait très bien sur mon vieux site www.breizh-bijoux.com mais paypal a modifié la sécurité je dois donc changer l'environnement dans ovh (ovh me dit le mettre à stable), et le problème c'est que je ne peux pas le faire car il faut au minimun php5.4 et il est en 5.3.29 et du coup mon module paypal risque de ne pas fonctionner. mais j'ai beaucoup bidouillé le site pour avoir un design différent suivant les categories et je pense avoir fait d'autres trucs mais je ne me souviens pas de tout , c'était il y a longtemps et mes neurones ont atteint 68 ans et comme le site fonctionnait bien après une petite modif , je n'ai pas mis le nez dans le code depuis pas mal de temps
Quelqu'un peut-il me dire quelle est la version qui est 5.4 pour que je fasse rapidement au moins les mises à jours jusqu'à cette version je ferai les autres ensuite (pourinfo je ne travaille pas en local mais je fais un site mirroir avec la même base de donnée et je travaille sur ce site mirroir )
la dernière version est-elle en 5.5 ?
merci d'avance
Fran

Ce message a été modifié par frannyz - 20 Jun 2018, 11:43.


--------------------
version 2.31
tout ce que je sais, c'est que je ne sais rien......mais j'apprends
Go to the top of the page
 
Bonbec
posté 20 Jun 2018, 12:50
Message #2


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1440
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,

La dernière version officielle, la 2.3.4.1 requiert PHP v4+ (v5+ recommandé) et MySQL v3+ (v5+ recommandé). Elle fonctionne avec PHP 5.6 au moins :
https://www.oscommerce.com/Products

il existe aussi une version non officielle mais supportée par la communauté OsCommerce anglophone, la 2.3.4.1BS Edge :
https://github.com/gburton/osCommerce-234-b...hive/master.zip
Cette version fonctionne jusqu'à PHP 7 (mais pas PHP 7.2). C'est "responsive", c'est à dire que le site s'adapte automatiquement à l'appareil qui l'affiche, que ce soit téléphone, tablette, ordinateur. Chose que les autres versions d'OsCommerce ne faisaient pas.

Autrement en gardant le site actuel, le passage de PHP 5.3 à PHP 5.4 n'engendre pas trop de modifications, voir :
http://php.net/manual/fr/migration54.php
N'étant pas chez OVH, c'est possible d'avoir des versions de PHP différentes selon les répertoires ?
Si oui, cela permettrait de tester une copie du site actuel en PHP 5.4.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 18th August 2018 - 21:39
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)