osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> probleme charset latin 1 et utf8
taiko
posté 20 Jan 2018, 14:59
Message #1


Ceinture marron OSC
Icône de groupe

Groupe : Membres
Messages : 1684
Inscrit : 20-April 07
Lieu : chez mickey
Membre no 16736



salut

je rencontre un problème suite à la mise a jour de php 5.6 par un developpeur qui m'a laissé tombé et laissé le site en plan car il ne voulait pas terminé la mise a jour soit disant que c'était trop long, donc je me retrouve avec des modifs faites a moitié et des problèmes d'accent dans l'admin alors j'en ai réglé quelques uns dans le fichier french en remplaçant les é, è ect... apr leur valeur html ça fonctionne par contre ce qui est en base de donnée pour les fiches produits j'ai essayé de modifié le fichier de la base et l'importer a nouveau pour modifié tous les accents d'un coup et la beau message d'erreur suivant :

une idée d'ou chercher y a un conflit, toutes les tables de la bases sont en iso, le charset des fichiers toujours en iso aussi je pense.


1267 - Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation 'like'

SELECT cat.categories_id FROM categories as cat, categories_description as des WHERE cat.categories_id = des.categories_id AND des.language_id = 1 AND cat.parent_id = 405 AND des.categories_name like 'Sauna ext�rieur infrarouge'

j'ai modifié l'interclassement de la base mais ça change rien

merci



--------------------
oscommerce ms2.2 delaballe, header tag controller v2-6-3, Agree2Terms_v1.6.7, MS2-2.2-SiteMap-SEO-URLs-withproducts (bientot), sponsorship v2.2,pack_newsletters, pack_newsletters, Prof_Invoice&PackingSlip_v0.2(fr+stylesheet) (je crois), checkout_confirmation_chg_valid_xhtml, + d'autres mais je sais plus trop a force.
Go to the top of the page
 
Bonbec
posté 22 Jan 2018, 15:51
Message #2


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1375
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Toucher aux BDD n'est pas mon fort wacko.gif
Alors j'ai laissé la BDD comme elle était et j'ai modifié les scripts pour transformer en utf-8 et les pages d'affichages sont sauvegardées en UTF-8 sans BOM.
Cela fonctionne, mais c'est pas très propre comme solution.


--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 
Havock
posté 29 Jan 2018, 09:09
Message #3


Ceinture bleue OSC
Icône de groupe

Groupe : Membres
Messages : 898
Inscrit : 4-February 04
Membre no 1926



Hello gentlemen,

Les questions de charset sont assez pénibles quand on doit switcher de l'un à l'autre et c'est encore plus galère quand on a des mix de charset (entre la connexion à la base, les structures des tables et les données présentes dans les tables blink.gif blink.gif blink.gif ).

Regarde ici https://stackoverflow.com/questions/3029321...-error-in-mysql ça pourra peut-être t'aider.



--------------------
L'indispensable est en cours de traitement,
L'urgent sera traité demain,
Le normal sera traité plus tard,
Le reste on vera ...
En conclusion : les journées sont trop courtes.
Utilisateur de MS2.2 Max 1.5 - OSC-Affiliate 1.09 - Admin With Access Levels 2.1 - Meta Tag Controller/ Generator - Credit/Gift Voucher/Coupons 5.05 - Download Controller v5.3 - X-Sell MS2 - WYSIWYG HTML Editor for Admin 1.7 - Dynamic Mo Pics - Loginbox Best - Order logging before payment processing - User Tracking - Faster Page Loads, Less DB queries - Plus plein de modifs perso :-)
Go to the top of the page
 
taiko
posté 30 Jan 2018, 20:43
Message #4


Ceinture marron OSC
Icône de groupe

Groupe : Membres
Messages : 1684
Inscrit : 20-April 07
Lieu : chez mickey
Membre no 16736



Salut

Merci a vous deux.
Je viens de voir vos messages.
Cet après midi j ai passe l aprem a essayer de retablir la base donnee avec les accents.
J ai efface les tables products et toutes celles qui y sont rattachés et j ai reimporte la base avec les accents et j ai toujours le même problème sur le site avec des lettres a la place des accents.
Je sais pas exactement ce qu il a modifié mais c est la mierda.
Il y a aussi un probleme de language si je clique sur le drapeau anglais ca passe en anglais et apres des que je clic sur un lien tius les liens renvois en français, une misère.

Une idée d ou chercher ?

Que veut tu dires fred pour sauvegarde en utf8 sans bom ?

Merci




--------------------
oscommerce ms2.2 delaballe, header tag controller v2-6-3, Agree2Terms_v1.6.7, MS2-2.2-SiteMap-SEO-URLs-withproducts (bientot), sponsorship v2.2,pack_newsletters, pack_newsletters, Prof_Invoice&PackingSlip_v0.2(fr+stylesheet) (je crois), checkout_confirmation_chg_valid_xhtml, + d'autres mais je sais plus trop a force.
Go to the top of the page
 
Bonbec
posté 31 Jan 2018, 01:37
Message #5


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1375
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Ton site actuel est déclaré en iso-8859-1 et l'affichage des accents foire. Par contre si je passe l'affichage de mon navigateur en unicode, c'est tout bon. Donc on va reprendre à zéro car à mon avis il y a un mélange d'encodage :

1) ta base de donnée est en latin1_swedish_ci ou en utf8_general_ci ?

2) ton charset dans le fichier de langue catalog/includes/languages/french est define('CHARSET', 'utf-8'); ou define('CHARSET', 'iso-8859-1'); ?




--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc 2.3.4 BS
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 21st February 2018 - 11:55
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)