osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> [RESOLU] Page blanche / Erreur HTTP 500, plus de catalog ni admin
Dudule
posté 8 Mar 2021, 01:28
Message #1


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 198
Inscrit : 9-December 02
Lieu : Bordeaux
Membre no 654



Bonjour,

Ma boutique n'est plus accessible depuis quelques temps sans que j'y touche.
Firefox m'affiche une page blanche et Chromanium me dit qu'il y a une erreur : HTTP ERROR 500

J'ai l'erreur aussi bien dans la partie catalog que dans admin.
J'ai juste l'identification dans l'admin : zone protégée.
Je n'ai touché à rien.
J'ai un autre site en 100% html chez le même hébergeur qui continu à bien fonctionner.
L'hébergeur est O2switch.
Il m'affiche comme erreurs : [Sun Mar 07 21:03:02.758016 2021] [:error] [pid 2665040:tid 46957411718912] [client 185.56.80.65:0] File does not exist: /home/xxxx/public_html/index.php

Une idée ?
Merci

Ce message a été modifié par Dudule - 13 Mar 2021, 22:18.


--------------------
osCommerce Online Merchant v2.2 RC1 W3C Valid FR en prod en PHP5.2.14 chez O2Switch
Go to the top of the page
 
Bonbec
posté 8 Mar 2021, 09:15
Message #2


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1520
Inscrit : 30-May 06
Lieu : Vichy (03)
Membre no 10583



Bonjour,
Je suis aussi (pour quelques jours encore) chez O2Switch.
Le message d'erreur t'indique que le fichier index.php n'existe pas.As-tu regardé si il était toujours présent ?
Sinon, de manière générale, l'error 500 indique que le serveur n'a pas compris une instruction, soit de code php, soit d'une règle de .htaccessTu peux vérifier dans ton cPanel la version de Php installée, pour voir si elle correspond à ta version d'OsCommerce.Une fois O2Switch avait basculé tout un serveur en php7.3 et mon site était en carafe ... A l'époque je l'avais rebasculé en php5.6 pour que çà refonctionne correctement.

PS1 : l'adresse IP indiquée dans ton message d'erreur est une adresse des Seychelles. Ton site n'aurait pas fait l'objet d'une attaque ?
PS2 : même tes pages account.php et login.php ne semblent plus être présentes ...



--------------------
Config 1 en live : Osc 2.2 très fortement modifié ... UTF-8 et Php 5.4.
Contribs installées : down_for_maintenance_v 2.3 | Estimated Shipping v1.5 | imprint_1_3_5 | low_stock_report_v2.04 | visible_countries_1.2b | Products Tabs | shoppingCart_cleanup_v1.01.0 | + trop de bidouilles persos pas très OsCommerce (erreurs de jeunesse)
Config 2 en local avec UwAmp : Osc Phoenix
Go to the top of the page
 
Dudule
posté 13 Mar 2021, 22:16
Message #3


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 198
Inscrit : 9-December 02
Lieu : Bordeaux
Membre no 654



Bonjour,

Merci pour ta réponse, c'était bien en raapart avec le fichier .htacces

J'ai envoyé un message à O2switch et ils ont corrigé l'erreur. Cela faisait depuis la dernière semaine de février que le site était en panne sans que je m'en aperçoive.
Ils ont dû changer quelque chose.

Le fichier https://www.lepiedfrancais.fr/version.php fonctionnait, c'était tous les autres fichiers qui était bien présents, mais qui ne s'affichaient pas.

Voici leur réponse :
Vous aviez forcé le PHP 5.2 dans le .htaccess du site mais sans mettre de php.ini avec la configuration nécessaire au fonctionnement de cette version de PHP.

J'ai donc rajouté dans le .htacces la ligne "suPHP_ConfigPath /home/xxxx/yyyy" et mis le fichier php.ini dans ce dossier et ça marche.


--------------------
osCommerce Online Merchant v2.2 RC1 W3C Valid FR en prod en PHP5.2.14 chez O2Switch
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 17th April 2021 - 09:34
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)