osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Des requêtes ne s'exécutent pas correctement sur le serveur, cela m'a effacé toutes mes catégories!!!!
jolilo
posté 31 Jul 2011, 11:36
Message #1


Ceinture verte OSC
Icône de groupe

Groupe : Membres
Messages : 610
Inscrit : 4-February 06
Lieu : pau
Membre no 8911



Bonjour,

nous rencontrons des problèmes avec notre serveur dédié.
La société qui le géré nous dit que cela ne vient pas de chez eux mais j'ai un doute.
dernièrement, hier soir, nous avons juste effacer une sous catégorie.
oscommerce a commencé à mouliner et puis toutes mes catégories avec les produits ont disparu.

Oui je sais c'est une catastrophe, le point positif c'est que j'ai des backup journalier donc j'ai prévenu la société mais un dimanche il faut attendre.

Je me demande si cela vient de mon oscommerce poussif (date de 2005 mais mis à jour régulièrement) ou si cela peut venir de mon serveur?

Je ne trouve pas normal qu'en envoyant une requête simple tout ce soit effacé.
de plus il n'est pas possible d'effacer toutes les catégories sans passer par un drop table alors que ce n'est pas le cas.
Enfin en local j'ai reproduit l'effacement et tout fonctionne correctement.

Pouvez vous me dire si vous avez rencontré cela? et si je dois hausser le ton avec mon hebergeur?

merci d'avance
Florian


--------------------
osCommerce 2.2-MS2
QT Pro Version 4.0 modifications
CCGV 5.16, Newsdesk, Sitemap MS2 2.3, Headertags, Ultimate SEO 2.2.2, Giftwrap 1.1, sponsorship, supermailer,

Site 2 en construction: oscommerce-2.2rc1-FR-w3c-3
ACA v2.6SP1, ultimate seo v21e_1, Product Tabs 2.2, Contrib_Installer_2.2 (bug), QTpro 4.5, Headre tags 2.2, FCK editor 2.6 (ne marche pas avec categorie tabs), ultimate seo 2.1 et le reste en cours.
Go to the top of the page
 
FoxP2
posté 31 Jul 2011, 21:00
Message #2


Ceinture marron OSC
Icône de groupe

Groupe : Modérateurs
Messages : 1665
Inscrit : 3-June 09
Membre no 25501



Citation
je ne trouve pas normal qu'en envoyant une requête simple tout ce soit effacé.

c'est à dire ?


--------------------


Go to the top of the page
 
Gnidhal
posté 31 Jul 2011, 21:45
Message #3


5eme dan OSC
Icône de groupe

Groupe : Administrateur
Messages : 9203
Inscrit : 4-March 03
Lieu : Auray
Membre no 927



C'est une erreur de manip assez courante.
En fait, quand tu effaces une sous-catégorie, il arrive que la catégorie ne soit pas correctement sélectionnée.
Résultat : le cID est à 0 => lors de l'effacement c'est la racine du catalogue qui est pointée et le récursif se fait sur les catégories filles : TOUS le catalogue!
Donc avant de confirmer l'effacement d'une catégorie, il faut bien lire ce qui est écrit au dessus du bouton "confirmer" (nombre de catégories concernées, nombre de produits concernés), ce qu'on ne fait généralement pas car on est sur d'avoir bien sélectionné la ligne.
Et paf!
Quant au délai pour récupérer la sauvegarde, c'est balot, mais c'est le cas chez la plupart des hébergeurs.

Et j'espère que tu as aussi une sauvegarde de tous tes fichiers image des produits, car dans la plupart des cas, la procédure d'effacement des produits efface aussi les images!
Perso, j'ai viré la ligne
@unlink(DIR_FS_CATALOG_IMAGES . $product_image['products_image']);
de la fonction tep_remove_products (dans general.php de l'admin), ça évite déjà l'effacement violent des images.

Donc quand on supprime une catégorie, 2 précautions à prendre :
1 faire une sauvegarde de la bdd avant (ça évite de devoir repartir de la sauvegarde de l'hébergeur)
2 vérifier que toutes les images sont bien au chaud sur ton disque local (copie miroir régulière par FTP de ton site)

Et surtout vérifier à 2 fois le message de confirmation!

Mais je te console, tu n'es pas le premier à qui ça arrive!


--------------------
Tout d'abord : - Ni Hotline ni Service Après Vente, ces forums sont un lieu d'échange. BIEN POSER SA QUESTION (généralités)
Les "Informations Importantes" que vous devez ABSOLUMENT avoir lues :
Règlement, Bien poser sa question dans ces forums et Bien utiliser les Forums.
Les raccourcis pour gagner du temps : la FAQ, les PDF de la Doc (MS2-fr): PDF-V1 et PDF-V2, le moteur de Recherche sur les forums , la Liste des Contributions de Corbin.

----------------------------- Quelques sites de référence ---------------------------
PHP: Le site du Zéro et PHP Débutant avec la DOC en français -- HTML: Self HTML - WebProgrammation -- CSS: OpenWeb - AlsaCréations - CSS/Edge -- Autres ressources: - XajaX - highslide js
Les bons outils : EasyPHP - WAMP-5 - - Notepad++ - Firefox et son extension WebDeveloper
Le gène idéal c'est le gène original. Le génie des halles est un Génie des Alpages qui tente d'être à la page. (Merci f'murrr pour les cours de philosophie de chien)
Go to the top of the page
 
jolilo
posté 1 Aug 2011, 07:27
Message #4


Ceinture verte OSC
Icône de groupe

Groupe : Membres
Messages : 610
Inscrit : 4-February 06
Lieu : pau
Membre no 8911



Bonjour,

merci beaucoup pour cette explication.

Effectivement toutes mes images ont disparu mais mon hebergeur a une sauvegarde de mes fichiers.

Pour l'attente ils m'ont tout remis hier soir, j'ai juste du remettre mes commandes et mes clients à jour.

Mon hebergeur est une très bonne société, très sérieuse mais comme ce n'est pas mon domaine je me suis méfié quand même.

Enfin j'ai une explication et tout va rentrer dans l'ordre dans la journée.

c'est donc une bonne journée qui démarre.

merci
Florian


--------------------
osCommerce 2.2-MS2
QT Pro Version 4.0 modifications
CCGV 5.16, Newsdesk, Sitemap MS2 2.3, Headertags, Ultimate SEO 2.2.2, Giftwrap 1.1, sponsorship, supermailer,

Site 2 en construction: oscommerce-2.2rc1-FR-w3c-3
ACA v2.6SP1, ultimate seo v21e_1, Product Tabs 2.2, Contrib_Installer_2.2 (bug), QTpro 4.5, Headre tags 2.2, FCK editor 2.6 (ne marche pas avec categorie tabs), ultimate seo 2.1 et le reste en cours.
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 23rd April 2014 - 10:12
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)