osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> [RESOLU]order_editor_for2.3_v1.0, Ajax ne fonctionne pas completement
francois21
posté 6 Jun 2011, 20:11
Message #1


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 225
Inscrit : 4-September 06
Lieu : dijon
Membre no 11890



Bonjour
J'ai installé la contribution ci dessus , tout c'est bien passé.
Quand je veux editer une commande, certaines fonctions ajax fonctionnent, changement de quantité par exemple, mais ajouter un produit ou modifier les frais de port ne fonctionnent pas(la page ne se recharge pas).
Pourtant quand je reviens sur la page apres actualisation, certaines modifs sont prisent en compte.
Une idée??
Quelqu'un a installé cette contribution?
Fonctionne t'elle?

Merci
Francois

Ce message a été modifié par francois21 - 7 Jun 2011, 10:11.


--------------------
Francois

Osco 2.31 avec pas mal de modifs qui fonctionnent.
Go to the top of the page
 
Gnidhal
posté 6 Jun 2011, 21:13
Message #2


5eme dan OSC
Icône de groupe

Groupe : Administrateur
Messages : 9206
Inscrit : 4-March 03
Lieu : Auray
Membre no 927



Peut-être un peu délicat à régler comme problème : il n'est pas exclus que l'ajax utilisé par ces scripts vienne marcher sur les pieds du jQuery chargé dans tous les scripts.
Si tu connais le code et le debuggage javascript, on sera content de profiter de ta solution smile.gif car dans ce domaine, il faut vraiment avoir la même config pour trouver ce qui bloque.


--------------------
Tout d'abord : - Ni Hotline ni Service Après Vente, ces forums sont un lieu d'échange. BIEN POSER SA QUESTION (généralités)
Les "Informations Importantes" que vous devez ABSOLUMENT avoir lues :
Règlement, Bien poser sa question dans ces forums et Bien utiliser les Forums.
Les raccourcis pour gagner du temps : la FAQ, les PDF de la Doc (MS2-fr): PDF-V1 et PDF-V2, le moteur de Recherche sur les forums , la Liste des Contributions de Corbin.

----------------------------- Quelques sites de référence ---------------------------
PHP: Le site du Zéro et PHP Débutant avec la DOC en français -- HTML: Self HTML - WebProgrammation -- CSS: OpenWeb - AlsaCréations - CSS/Edge -- Autres ressources: - XajaX - highslide js
Les bons outils : EasyPHP - WAMP-5 - - Notepad++ - Firefox et son extension WebDeveloper
Le gène idéal c'est le gène original. Le génie des halles est un Génie des Alpages qui tente d'être à la page. (Merci f'murrr pour les cours de philosophie de chien)
Go to the top of the page
 
francois21
posté 7 Jun 2011, 10:11
Message #3


Ceinture orange OSC
Icône de groupe

Groupe : Membres
Messages : 225
Inscrit : 4-September 06
Lieu : dijon
Membre no 11890



Bonjour
Merci pour la reponse.
Dans le doute, j'ai testé sur un autre pc et tout fonctionne apres la correction d'une erreur dans le fichier edit_order_ajax.
if ( FILENAME_EMAIL_ORDER_TEXT !== ?FILENAME_EMAIL_ORDER_TEXT? )
remplacer par
if ( FILENAME_EMAIL_ORDER_TEXT !== FILENAME_EMAIL_ORDER_TEXT )

Surement une configuration différente de wamp ou je ne sais quoi et les erreur ne s'affichaient pas sur mon pc.
Donc tout est ok


--------------------
Francois

Osco 2.31 avec pas mal de modifs qui fonctionnent.
Go to the top of the page
 

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 20th December 2014 - 20:25
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)