osCommerce France : Accueil Forum Portail osCommerce France Réponses aux questions Foire aux contributions

Bienvenue invité ( Connexion | Inscription )

> Error: Catalog images directory does not exist: /xxxxxx/images/
roiphoto
posté 30 Dec 2017, 14:16
Message #1


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 119
Inscrit : 6-August 07
Lieu : 93200
Membre no 18622



Bonjour

Error: Catalog images directory does not exist: /xxxxxx/images/
Oscommmerce2.2rc2a + bannertop +MATC + iOSc Mobile
php 5.6.19

Mon projet fonctionnait 5 sur 5 en local.

Je l’ai hébergé en mutualisé linux et j’ai envoyé tous fichiers et dossiers par ftp dans
xxxx/public_html/

Le site n’apparaît pas.

J’ai demandé l’aide du service technique de mon hébergeur et promptement mon site devient visible. Le service technique a réagi en corrigeant ce qui était mal fait mais ne m’a pas expliqué ce qui s’était passé !

Puis impossibilité de me connecter à mon admin

J’ai bidouillé mes configure.php et je réussis à me connecter à mon admin du côté hébergeur

Mon problème actuel est que quand je veux ajouter ou modifier un produit à partir de l’admin côté hébergeur, l’image ne se télécharge pas et une alerte. Mais toutes les anciennes images avant l’intervention du service technique sont présentes et fonctionnent bien

Alerte : Catalog images directory does not exist.

Une autre question sur le même sujet : pour envoyer les fichiers à l’hébergeur par ftp, dans quel dossier dois-je les mettre : dans public_html ou dans www ?

Toutes les aides sont attendues !

Je vous remercie
Go to the top of the page
 
 
Start new topic
Réponse(s)
roiphoto
posté 7 Jan 2018, 15:51
Message #2


Ceinture jaune+ OSC
Icône de groupe

Groupe : Membres
Messages : 119
Inscrit : 6-August 07
Lieu : 93200
Membre no 18622



Bonjour

Pour l’évolution de ma situation j’ai mis les bonnes infos dans
includes/configure.php et j’ai retrouvé tous mes modules de livraison et paiement sont revenus. De plus le téléchargement des images redevient correct.

Pour ceux qui rencontreraient les même difficultés et si cela peut aider, voici la partie qui bloquait

define('HTTP_COOKIE_DOMAIN', 'http://www.monsite.com');
define('HTTPS_COOKIE_DOMAIN', 'http://www.monsite.com');
define('HTTP_COOKIE_PATH', '/monsite/');
define('HTTPS_COOKIE_PATH', '/monnsite/');
define('DIR_WS_HTTP_CATALOG', '//');
define('DIR_WS_HTTPS_CATALOG', '//');

Il reste :
- que la commande ne s’affiche dans l’admin mais elle parvient dans la notification par email au propriétaire du site
- le client ne reçoit pas mes coordonnées après l’achat et ça, je réfléchis sur les modifs que j’avais apportées au /checkout_process.php

Je vous remercie

Go to the top of the page
 

Les messages de ce sujet


Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 20th May 2022 - 21:21
Ce site est déclaré auprès de la commision Nationale
de l'Informatique et des Libertés (déclaration n°: 1043896)